more than one ip range

José Queiroz zekkerj at gmail.com
Wed Apr 27 14:32:46 UTC 2011


Em 27 de abril de 2011 00:33, Usuário do Sistema <maiconlp at ig.com.br>escreveu:

>
> in my switch structure all it's ready....I have switch Cisco and I've
> configuration ip helper address in my vlan 1.
>
>
Hi "Usuário do Sistema",

Check that you have an "ip helper-address" configured in each vlan
interface, except that one that reach the DHCP server.

In example, said you have VLANs 10, 20 and 30. So you have these interfaces
on your switch (I'm suposing you're using a L3 switch):

interface vlan 10
  ip address 192.168.10.1 255.255.255.0
  ip helper-address 192.168.30.30
!
interface vlan 20
  ip address 192.168.20.1 255.255.255.0
  ip helper-address 192.168.30.30
!
interface vlan 30
  ip address 192.168.30.1 255.255.255.0
!

As the DHCP server is part of VLAN 30, there's no need to include an "ip
helper-address" in VLAN 30.

By the way, you know that you can configure your DHCP server directly in the
L3 Switch (suposed that you're using a Catalyst Switch)?

ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp excluded-address 192.168.30.1 192.168.30.10
ip dhcp pool VLAN10
  network 192.168.10.0 255.255.255.0
  default-router 192.168.10.1
  dns-server 8.8.8.8
!
ip dhcp pool VLAN20
  network 192.168.20.0 255.255.255.0
  default-router 192.168.20.1
  dns-server 8.8.8.8
!
ip dhcp pool VLAN30
  network 192.168.30.0 255.255.255.0
  default-router 192.168.20.1
  dns-server 8.8.8.8
!

This is a good alternative if you don't have a DHCP server configured now,
or if you don't need the extra resources offered by a full featured DHCP
Server like ISC DHCP.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20110427/f8fb5908/attachment.html>


More information about the dhcp-users mailing list