CVE-2015-5986: An incorrect boundary check can trigger a REQUIRE assertion failure in openpgpkey_61.c

Document Version: 2.0
Posting date: 02 September 2015
Program Impacted: BIND
Versions affected: 9.9.7 -> 9.9.7-P2, 9.10.2 -> 9.10.2-P3.
Severity: Critical
Exploitable: Remotely

Description:

An incorrect boundary check in openpgpkey_61.c can cause named to terminate due to a REQUIRE assertion failure.  This defect can be deliberately exploited by an attacker who can provide a maliciously constructed response in answer to a query.

Impact:

A server which encounters this error will terminate due to a REQUIRE assertion failure, resulting in denial of service to clients.

Recursive servers are at greatest risk from this defect but some circumstances may exist in which the attack can be successfully exploited against an authoritative server.  Servers should be upgraded to a fixed version.

CVSS Score:  7.1

CVSS Vector:  (AV:N/AC:M/Au:N/C:N/I:N/A:C)

For more information on the Common Vulnerability Scoring System and to obtain your specific environmental score please visit: http://nvd.nist.gov/cvss.cfm?calculator&adv&version=2&vector=(AV:N/AC:M/Au:N/C:N/I:N/A:C)

Workarounds:

No workarounds are known to exist.

Active exploits: 

None known.

Solution:

Upgrade to the patched release most closely related to your current version of BIND. These can all be downloaded from http://www.isc.org/downloads.

  • BIND 9 version 9.9.7-P3
  • BIND 9 version 9.10.2-P4

BIND development releases scheduled to be published at the same time as the public disclosure of this vulnerability will also contain the fix for this security issue.

  • BIND 9 version 9.9.8rc1
  • BIND 9 version 9.10.3rc1

Document Revision History:

1.0 Advance Notification 19 August, 2015
2.0 Public Disclosure  2 September, 2015

Related Documents:

See our BIND9 Security Vulnerability Matrix at https://kb.isc.org/article/AA-00913 for a complete listing of Security Vulnerabilities and versions affected.

If you’d like more information on ISC Subscription Support and Advance Security Notifications, please visit http://www.isc.org/support/.

Do you still have questions?  Questions regarding this advisory should go to security-officer@isc.org.  To report a new issue, please encrypt your message using security-officer@isc.org’s PGP key which can be found here: https://www.isc.org/downloads/software-support-policy/openpgp-key/.  If you are unable to use encrypted email, you may also report new issues at: https://www.isc.org/community/report-bug/.

Note: ISC patches only currently supported versions. When possible we indicate EOL versions affected.  (For current information on which versions are actively supported, please see http://www.isc.org/downloads/).

ISC Security Vulnerability Disclosure Policy:  Details of our current security advisory policy and practice can be found here: https://kb.isc.org/article/AA-00861/164/ISC-Software-Defect-and-Security-Vulnerability-Disclosure-Policy.html

This Knowledge Base article https://kb.isc.org/article/AA-01291 is the complete and official security advisory document.

Legal Disclaimer: 
Internet Systems Consortium (ISC) is providing this notice on an “AS IS” basis. No warranty or guarantee of any kind is expressed in this notice and none should be implied. ISC expressly excludes and disclaims any warranties regarding this notice or materials referred to in this notice, including, without limitation, any implied warranty of merchantability, fitness for a particular purpose, absence of hidden defects, or of non-infringement. Your use or reliance on this notice or materials referred to in this notice is at your own risk. ISC may change this notice at any time.  A stand-alone copy or paraphrase of the text of this document that omits the document URL is an uncontrolled copy. Uncontrolled copies may lack important information, be out of date, or contain factual errors.

 

© 2001-2015 Internet Systems Consortium

Last modified: September 2, 2015 at 12:42 pm